Running a batch file via command component

Jun 23, 2010 at 2:52 PM

I'm trying to run a batch file that configures product A, which just got installed, and it must happen before product B gets installed.  So my DNI config looks like this:

install product A
run batch file
install product B

Problem is that sometimes the run of the batch file fails, with a DNI return code of 7.  Usually it works, but sometimes it doesn't. 
What does return code 7 mean?

Here's a snip from the log:

2010-06-23 10:39:59    Extracting embedded files for component 'Run MySQL Configurator': 1 CAB(s)
2010-06-23 10:39:59    Resolved CAB path 'C:\Users\GAP~1.GRO\AppData\Local\Temp\{CA379F31-C991-4169-A660-29E631E4B5AC}' for component 'RUN_MYSQL_CONFIGURATOR'
2010-06-23 10:39:59    Extracting 'SETUP_RUN_MYSQL_CONFIGURATOR_FOR_SFTP_1.CAB' for component 'RUN_MYSQL_CONFIGURATOR'
2010-06-23 10:39:59    Extracting: C:\Users\GAP~1.GRO\AppData\Local\Temp\{CA379F31-C991-4169-A660-29E631E4B5AC}\MySQLConfig.bat
2010-06-23 10:39:59    Done: C:\Users\GAP~1.GRO\AppData\Local\Temp\{CA379F31-C991-4169-A660-29E631E4B5AC}\MySQLConfig.bat
2010-06-23 10:40:00    Executing: cmd.exe /C C:\Users\GAP~1.GRO\AppData\Local\Temp\{CA379F31-C991-4169-A660-29E631E4B5AC}\MySQLConfig.bat
2010-06-23 10:40:35    --- Component 'Run MySQL Configurator (Run MySQL Configurator): DIALOG CLOSED
2010-06-23 10:40:35    *** Component 'Run MySQL Configurator' (Run MySQL Configurator): ERROR - Error executing 'Run MySQL Configurator' (Run MySQL Configurator): 0x7
2010-06-23 10:40:35    --- Component 'Run MySQL Configurator (Run MySQL Configurator)' FAILED: Error executing 'Run MySQL Configurator' (Run MySQL Configurator): 0x7
2010-06-23 10:41:35    --- Component 'Run MySQL Configurator (Run MySQL Configurator): FAILED, ABORTING
2010-06-23 10:41:36    Deleting temporary folder: C:\Users\GAP~1.GRO\AppData\Local\Temp\{CA379F31-C991-4169-A660-29E631E4B5AC}
2010-06-23 10:41:36    dotNetInstaller finished, return code=7

Thanks...

Jun 23, 2010 at 9:15 PM

Duh, I figured it out... I think my batch file is returning a 7.