Minimum Installation Requirements Error

Jul 8, 2010 at 7:27 PM
I put a minimum OS requirement on a configuration (os_filter_min="winXPsp3"). The idea is that the package has a minimum OS requirement and the hope was that there would be a nice error stating that their OS needed to be upgraded to Windows XP SP3. Instead I got the error message "No configuration matching locale and operating system found within 1 configuration(s)". Sure that makes perfect sense to a developer (or at least one familiar with dotNetInstaller), but that message ain't going to fly. Any suggestions? Could we add a message property for minimum OS requirements not meet for any package? Thanks! Nate
Jul 8, 2010 at 7:35 PM

It's configuration_no_match_message at the config file configuration level.

Jul 8, 2010 at 7:48 PM
Awesome. Thanks!
Jul 27, 2010 at 1:25 AM
Thank you dblock, I am wondering how we can make the string in configuration_no_match_message localized for the lcidtype? For example, since configuration_no_match_message is on the <configurations /> level, it does not seem like we can use a different string for each language - is this true? If someone is running on en-US locale, I want it to display "This application requires Windows XP or higher". If someone is running on fr-FR locale, I want it to display "Cette application nécessite Windows XP ou supérieur". Is this possible using only one exe generated from dotNetInstaller? Thank you.
Jul 27, 2010 at 3:28 AM

Ce n'est pas possible avec la version actualle. Le choix de la langue se fait au niveau d'une configuration individuelle. Tu peux creer une "feature request" si tu veux. Je ne suis pas certain que ce soit facile d'implementer sans faire un "brain twist" :)

Jul 27, 2010 at 3:28 AM
Edited Jul 27, 2010 at 3:29 AM

Ce n'est pas possible avec la version actuelle. Le choix de la langue se fait au niveau d'une configuration individuelle. Tu peux creer une "feature request" si tu veux. Je ne suis pas certain que ce soit facile d'implementer sans faire un "brain twist" :)

Jul 27, 2010 at 4:04 AM
Thank you for the reply. I created a work item here: http://dotnetinstaller.codeplex.com/workitem/6720