.Net 3.5 Installation Issue?

Aug 16, 2010 at 2:33 PM

We have a customer that has a set of policies where they map their servers' c drive to an abitrary drive (say h:).  Then all access to the c drive is removed (effectively making h: the new c:).

When we install .Net 3.5 (and .Net 3.5 only), the dotnetinstaller reports that the installation failed.  However, there are no events logged indicating an msi failure and the framework does appear to install correctly.  Other components install without problems and the application itself installs without problems.  We replicated the client's environment on 3 VM's.  The first did not map the c drive (installation to c: as normal).  This installation worked.  The second VM we installed only the .Net 3.5 framework.  This worked without problems.  The 3rd recreated the situation described above.  This generated the error.  Any ideas on what may be going wrong?

For reference the component definition from configuration.xml is shown below.

 

    <component command="&quot;#APPPATH\Components\dotnetfx35.exe&quot; /c:install /norestart /qb" command_silent="" command_basic="" os_filter_greater="" os_filter_smaller="" os_filter_lcid="" type="cmd" installcompletemessage="" mustreboot="False" reboot_required="" must_reboot_required="False" failed_exec_command_continue="" allow_continue_on_error="False" required="True" description="Microsoft .NET Framework 3.5" note="English - Standard - .NET Framework 3.5" processor_architecture_filter="" status_installed="" status_notinstalled="">
      <installedcheck path="Software\Microsoft\NET Framework Setup\NDP\v3.5" fieldname="Install" fieldvalue="1" fieldtype="REG_DWORD" comparison="match" rootkey="HKEY_LOCAL_MACHINE" wowoption="NONE" type="check_registry_value" description="Installed Check" />
      <installedcheck path="SOFTWARE\Microsoft\NET Framework Setup\NDP\v3.5" fieldname="Version" fieldvalue="3.5.30729.01" fieldtype="REG_SZ" comparison="version" rootkey="HKEY_LOCAL_MACHINE" wowoption="NONE" type="check_registry_value" description="Installed Check" />
    </component>

Coordinator
Aug 16, 2010 at 4:18 PM
Edited Aug 16, 2010 at 4:18 PM

The first thing to do would be to post the dotNetInstaller log. It should say which error code is returned or log a failure from the code that executes the installer (if that's where the failure is).

The second thing is to install .NET framework manually an see if there're any errors.