Help with .net 4.0 installation - always failing when using /norestart switch

Jul 20, 2011 at 4:26 PM

Hi, I want to install .net 4.0, everything seems to work fine but the problem is that I don't want to reboot after installation finishes that's why I use the /norestart switch for installation. dotnetinstaller always prompt me for restarting, how can i disable this and in the same time to supress the mssage telling me that the installation of .net 4.0 failed ? (although it didn't).

here is a screenshot of the parameters I use

http://imageshack.us/photo/my-images/715/net4error.png/

 

Thank you.

Jul 20, 2011 at 11:05 PM

Examine the log from the installation. This installer probably returns an error code indicating to DNI that it wants it to reboot. If this is the case, you may need to specify to ignore those codes in the configuration (one of the returncodes_ ... options).