Cannot get exe to run and read its setup.ini file

Feb 24, 2012 at 3:39 PM

I am trying out the dotNetInstaller to allow me to chain several Visual Studio project msi's together. I need to run an exe prior to the msi's to install a USB to serial driver. I have created a exe component in the installer but it fails to run the exe because the exe needs a setup.ini file to run. I have included the file in the install directory and even tried to embed the ini file but it doesn't seem to work.

Everything else in the installer is working fine. The xml is below.

 

Anybody have an idea how I can run this exe ( CP210xVCPInstaller.exe ) and have it find its ini file?

 

 

<?xml version="1.0" encoding="UTF-8"?>
<configurations log_file="#TEMPPATH\dotNetInstallerLog.txt" log_enabled="False" productversion="" fileversion="" ui_level="full" configuration_no_match_message="" language_selector_cancel="Cancel" language_selector_ok="OK" language_selector_title="" show_language_selector="False" lcid_type="UserExe"> 
	<schema generator="dotNetInstaller InstallerEditor" version="2.0.81.0"/> 

	<configuration language="" supports_uninstall="True" supports_install="True" processor_architecture_filter="" os_filter_max="" os_filter_min="" os_filter="" language_id="" lcid_filter="" type="install" administrator_required_message="BAT Tools Suite installation requires administration rights." administrator_required="False" disable_wow64_fs_redirection="False" show_cab_dialog="True" show_progress_dialog="True" reboot_cmd="" auto_continue_on_reboot="False" auto_start="False" dialog_skip_button_position="" dialog_cancel_button_position="" dialog_install_button_position="" dialog_osinfo_position="" dialog_otherinfo_link_position="" dialog_bitmap_position="" dialog_message_position="" dialog_components_list_position="" dialog_position="" dialog_default_button="cancel" cab_path_autodelete="True" cab_path="#TEMPPATH\#GUID" cab_dialog_caption="" cab_cancelled_message="" cab_dialog_message="%s" dialog_show_required="True" dialog_show_uninstalled="True" dialog_show_installed="True" reload_on_error="True" auto_close					_on_error="False" auto_close_if_installed="True" wait_for_complete_command="True" complete_command_basic="" complete_command_silent="" complete_command="" dialog_otherinfo_link="" dialog_otherinfo_caption="" must_reboot_required="False" reboot_required="To continue the installation you must restart your computer. Restart now?" uninstalling_component_wait="Uninstalling %s. Wait, this operation could take some time ..." installing_component_wait="Installing %s. Wait, this operation could take some time ..." uninstallation_none="BAT Tools Suite is not installed!" installation_none="BAT Tools Suite is already installed!" uninstallation_completed="BAT Tools Suite uninstalled successfully!" installation_completed="BAT Tools Suite installed successfully!" failed_exec_command_continue="Failed to install %s. Continue with other components?" status_notinstalled="" status_installed=" (Installed)" cancel_caption="Close" uninstall_caption="Uninstall" install_caption="Install" skip_caption="Skip" dialog_bitmap="#APPPATH			\banner.bmp" dialog_message_uninstall="" dialog_message="In order to install BAT Tools Suite you must first install these components:" dialog_caption="BAT Tools Suite Installer"> 

		<component supports_uninstall="False" supports_install="True" processor_architecture_filter="" os_filter_max="" os_filter_min="winXPsp3" os_filter="" type="cmd" disable_wow64_fs_redirection="False" show_cab_dialog="False" show_progress_dialog="False" must_reboot_required="False" reboot_required="" failed_exec_command_continue="" status_notinstalled="" status_installed="" note="English - WebSetup - .NET Framework 4.0 - Full for all operating system since Windows XP SP3 (Install check)" selected_uninstall="False" selected_install="True" required_uninstall="False" required_install="True" default_continue_on_error="False" allow_continue_on_error="False" mustreboot="False" uninstallcompletemessage="" installcompletemessage="" os_filter_lcid="" uninstall_display_name="" display_name="Microsoft .NET Framework 4.0 - Full" id="Microsoft .NET Framework 4.0 - Full" returncodes_reboot="3010" returncodes_success="" uninstall_command_basic="" uninstall_command_silent="" uninstall_command="" command_basic="" command_siln				t="" command=""#APPPATH\\dotNetFx40_Full_setup.exe" "/norestart /q""> 

			<installedcheck type="check_registry_value" description="Installed Check" wowoption="NONE" rootkey="HKEY_LOCAL_MACHINE" comparison="match" fieldtype="REG_DWORD" defaultvalue="False" fieldvalue="1" fieldname="Install" path="SOFTWARE\Microsoft\NET Framework Setup\NDP\v4\Full"/> 
	
			<downloaddialog dialog_message="Press 'Start' to download the required components for installing Microsoft .NET Framework 4.0 - Full" dialog_caption="Microsoft .NET Framework 4.0 - Full - Download Components" buttoncancel_caption="Cancel" buttonstart_caption="Start" autostartdownload="False" dialog_message_sendingrequest="Sending request ..." dialog_message_connecting="Connecting ..." dialog_message_copying="Files are downloaded. Please wait ..." dialog_message_downloading="Download in progress. Please wait..."> 

				<download clear_cache="False" alwaysdownload="True" destinationfilename="dotNetFx40_Full_setup.exe" destinationpath="#TEMPPATH\dotNetRuntime_Download_#PID" sourcepath="" sourceurl="http://download.microsoft.com/download/1/B/E/1BE39E79-7E39-46A3-96FF-047F95396215/dotNetFx40_Full_setup.exe" componentname="Microsoft .NET Framework 4.0 - Full"/> 

			</downloaddialog> 
		</component> 
		<component supports_uninstall="False" supports_install="True" processor_architecture_filter="" os_filter_max="" os_filter_min="" os_filter="" type="exe" disable_wow64_fs_redirection="False" show_cab_dialog="True" show_progress_dialog="True" must_reboot_required="False" reboot_required="" failed_exec_command_continue="" status_notinstalled="" status_installed="" note="" selected_uninstall="True" selected_install="True" required_uninstall="True" required_install="True" default_continue_on_error="False" allow_continue_on_error="True" mustreboot="False" uninstallcompletemessage="" installcompletemessage="" os_filter_lcid="" uninstall_display_name="" display_name="Silicon Graphics USB-Serial Driver" id="Silicon Graphics USB-Serial Driver" returncodes_reboot="" returncodes_success="" uninstall_exeparameters_silent="" uninstall_exeparameters_basic="" uninstall_exeparameters="" exeparameters_silent="" exeparameters_basic="" exeparameters="" uninstall_responsefile_target="" uninstall_responsefile_source="" uninstall				_executable_basic="" uninstall_executable_silent="" uninstall_executable="" responsefile_format="none" responsefile_target="" responsefile_source="" install_directory="" executable_basic="" executable_silent="" executable="CP210xVCPInstaller.exe"/> 

		<component supports_uninstall="True" supports_install="True" processor_architecture_filter="" os_filter_max="" os_filter_min="" os_filter="" type="msi" disable_wow64_fs_redirection="False" show_cab_dialog="True" show_progress_dialog="True" must_reboot_required="False" reboot_required="" failed_exec_command_continue="" status_notinstalled="" status_installed="" note="" selected_uninstall="True" selected_install="True" required_uninstall="False" required_install="False" default_continue_on_error="False" allow_continue_on_error="True" mustreboot="False" uninstallcompletemessage="" installcompletemessage="" os_filter_lcid="" uninstall_display_name="" display_name="Universal Config Tool" id="Universal Config Tool" uninstall_cmdparameters_basic="/qb-" uninstall_cmdparameters_silent="/qn" uninstall_cmdparameters="/qb-" uninstall_package="" cmdparameters_basic="/qb-" cmdparameters_silent="/qn" cmdparameters="" package="#APPPATH\SetupConfigTool.msi"/> 

		<component supports_uninstall="True" supports_install="True" processor_architecture_filter="" os_filter_max="" os_filter_min="" os_filter="" type="msi" disable_wow64_fs_redirection="False" show_cab_dialog="True" show_progress_dialog="True" must_reboot_required="False" reboot_required="" failed_exec_command_continue="" status_notinstalled="" status_installed="" note="" selected_uninstall="True" selected_install="True" required_uninstall="False" required_install="False" default_continue_on_error="False" allow_continue_on_error="True" mustreboot="False" uninstallcompletemessage="" installcompletemessage="" os_filter_lcid="" uninstall_display_name="" display_name="MicroMax Programmer" id="MicroMax Programmer" uninstall_cmdparameters_basic="/qb-" uninstall_cmdparameters_silent="/qn" uninstall_cmdparameters="/qb-" uninstall_package="" cmdparameters_basic="/qb-" cmdparameters_silent="/qn" cmdparameters="" package="#APPPATH\MicroMaxSetup.msi"/> 

	</configuration> 
</configurations>

Feb 27, 2012 at 5:45 PM

Anyone?

Coordinator
Feb 27, 2012 at 7:04 PM

What happens when you run that exe on the command line? What is that EXE anyway and how does it find its setup.ini without the bootstrapper?

Feb 28, 2012 at 4:55 PM

I was able to locate another exe version of this file that did not need the ini and I have it working now. Thanks.