Unable to compile Code Set 40859

Feb 15, 2010 at 7:01 PM

Hello,

 I am trying to compile Code set 40859. Currently get Failed build dni.proj (95,5) error MSB4036.

I have followed the directions found in the "Contributors" section of the user guide for setting up the dev environment.

I have tried to compile both by cmd prompt "build all" as well as through VS 2005.  No luck yet.

Thanks for an advice given.

Mike

 

 

Coordinator
Feb 15, 2010 at 8:23 PM

Is it failing on <DeleteTree Directories="$(ReleaseDir)" />? Probably because ReleaseDir is in use or something like that. Post the output in red.

Feb 16, 2010 at 7:58 PM

Here is the message in red.

C:\Development\dotnetinstaller\dni.proj(95,5): error MSB4036: The "DeleteTree" task was not found. Check the following: 1.)The name of the task in the project file is the same as the name of the task class. 2.) The task class is "public" and implements the Microsoft.Build.Framework.ITask interface. 3.) The task is correctly declared with <UsingTask> in the project file, or in the *.tasks file located in the "C:\Windows\Microsoft.NET\Framework|v2.0.50727" directory.

Thank you  for your time and effort

Mike

Coordinator
Feb 16, 2010 at 8:13 PM

I see. This is because you're using an older version of MSBuild Community Tasks. These guys haven't released a new build, I have been building it off source code.

Get my private build of 1.3.0, let me know if that works.

Feb 17, 2010 at 3:45 PM

Ok, your private build has removed that issue.

My new set of errors begins with..

C:\Development\dotnetinstaller\Version.proj(16,5): error MSB4018: The "SvnVersion" task failed unexpectedly.

Followed by Same error code MSB41018: could not find svn.exe,

then 6 other messages related to MSBuild.Community.Tasks.Subversion, Microsoft.build.utilities

Did I download the wrong SVN.  The user guide sends you to TortoiseSVN.

Thank you,

Mike

 

Coordinator
Feb 17, 2010 at 4:07 PM

I think you need an actual client, TortoiseSVN is just a GUI utility.

http://www.collab.net/downloads/subversion/

Feb 17, 2010 at 9:23 PM

Ok, I believe I am pretty close.  I had a few more issues after getting the correct subversion.

Now, I am stuck on what I believe to be my last error

SHFB : error BHT0004: An older MSBuild version is being used.  Unable to build help project.

I have uninstalled and reinstalled Sandcastle a few times.  I have installed .Net Framework 3.5 sp1

Question, when you compile do get  0,0

I get 113 warnings, 1 Error

Thanks,

Mike

 

Coordinator
Feb 17, 2010 at 9:26 PM

You can live without building docs I am sure.

If you really want to fix this, make sure you are installing the version of Sandcastle that I am using, ie. a beta from May 2008 and with the Styles 2.4 patch.

Feb 18, 2010 at 1:57 PM

 

You are correct about that, I can live without building the docs.

Sorry to be such a pain, I was just following the directions found in the "Contributors" section of the user guide for setting up the dev environment.

Thank you very much for the time you gave me.

Mike

Developer
Nov 5, 2010 at 9:09 PM
Edited Nov 5, 2010 at 11:12 PM

The current Dni.shfbproj file has SHFBSchemaVersion=1.8.0.0 which can be built using msbuild 2.0, but this is different if SHFBSchemaVersion=1.8.0.1+.

 

Sandcastle Help File Builder Documentation Version 1.8.0.1 (Beta 1)

http://www.ewoodruff.us/shfbdocs/html/95c85ec6-9f23-426a-b0ad-6b10a0453eaf.htm

"All projects and components are now built using the .NET Framework 3.5 SP1."

 

Sandcastle Help File Builder 1.8.03 was the "stable" release and requires msbuild 3.5 to build shfbproj files.

 

Dni's build.cmd currently uses msbuild 2.0.

 

Unfortunately, 1.8 is no longer available for download from http://shfb.codeplex.com/.

 

Also see:

Sandcastle Help File Builder Documentation BHT0004: An older MSBuild version is being used

http://www.ewoodruff.us/shfbdocs/html/42262e8b-6aa4-4ca0-85cb-a395cabb96c7.htm

 

I created a feature request here: http://dotnetinstaller.codeplex.com/workitem/7575

 

The current work-around is to comment out the following lines in dni.proj:

<CallTarget Targets="doc" />
<CallTarget Targets="release" />
<CallTarget Targets="zip" />
<CallTarget Targets="installer" />

Coordinator
Nov 7, 2010 at 7:30 PM

Something I meant to do a long time ago :) Upgraded to Sandcastle 1.9 in rev. 57211.