1

Closed

os_filter does not work as expected for Windows XP 64 bit SP2

description

I believe that the os_filter is not working as expected for Windows XP 64 bit SP2.

A Simple example; when os_filter is set to winXPsp2 and the setup is run on Windows XP 64 bit SP2, I get the error "No configuration matching locale and operating system found within 1 configuration(s)".
This does not occur on the 32 bit version of Xp

Using version 1.10.7765.0

log follows:
2010-06-16 18:17:17 dotNetInstaller (DNI) started, version 1.10.7765.0
2010-06-16 18:17:17 Copyright (c) DevAge, Vestris Inc. & Contributors
2010-06-16 18:17:17 Operating system: Windows Server 2003 R2 Sp2
2010-06-16 18:17:17 Sequence: install
2010-06-16 18:17:17 -------------------------------------------------------------------
2010-06-16 18:17:17 Loaded configuration from embedded resource 'RES_CONFIGURATION'
2010-06-16 18:17:17 Loaded schema: version=1.10.7765.0, generator=dotNetInstaller InstallerEditor
2010-06-16 18:17:17 Loaded file1, display_name='file1'
2010-06-16 18:17:17 Loaded 1 component(s) from configuration type=1 (lcid_filter=, os_filter=winXPsp2, os_filter_min=, os_filter_max=, processor_architecture_filter=)
2010-06-16 18:17:17 --- Read 1 configuration(s)
2010-06-16 18:17:17 -- Loading supported configurations (lcid=1033)
2010-06-16 18:17:17 -- Loading supported configurations (lcid=1033)
2010-06-16 18:17:18 Error: No configuration matching locale and operating system found within 1 configuration(s)
2010-06-16 18:17:18 dotNetInstaller finished, return code=-1
Closed Jul 26, 2010 at 1:29 PM by
Released in 1.10.

comments

dblock wrote Jun 16, 2010 at 6:16 PM

This is already fixed in rev. 49360, please try build 1.10.9360.0.

jamesminns wrote Jun 17, 2010 at 6:14 PM

with build 1.10.9360.0, everything works as you said.
Thanks!